Previous Section Next Section Table of Contents Glossary Index

Chapter 5. The Clozure CL IDE

5.4. IDE Features

5.4.1. Editor Windows

You can open an editor window either by choosing Open from the File menu and then selecting a text file, or by choosing New from the File menu. You can also evaluate the expression (ed) in the listener window; in that case Clozure CL creates a new window as if you had chosen New from the File menu.

Editor windows implement Hemlock editing commands. You can use all the editing and customization features of Hemlock within any editor window (including listener windows).

5.4.2. The Lisp Menu

The Lisp menu provides several commands for interacting with the running Lisp session, in addition to the ways you can interact with it by evaluating expressions. You can evaluate a selected range of text in any editing buffer. You can compile and load the contents of editor windows (please note that in the current version, Clozure CL compiles and loads the contents of the file associated with an editor window; that means that if you try to load or compile a window that has not been saved to a file, the result is an error).

You can interrupt computations, trigger breaks, and select restarts from the Lisp menu. You can also display a backtrace or open the Inspector window. Checking for Updates

At the bottom of the Lisp menu is an item entitled "Check for Updates". If your copy of Clozure CL came from the Clozure Subversion server (which is the preferred source), and if your internet connection is working, then you can select this menu item to check for updates to your copy of Clozure CL.

When you select "Check for Updates", Clozure CL uses the svn program to query the Clozure Subversion repository and determine whether new updates to Clozure CL are available. (This means that on Mac OS X versions earlier than 10.5, you must ensure that the Subversion client software is installed before using the "Check for Updates" feature. See the wikiHow page on installing Subversion for more information.) If updates are available, Clozure CL automatically downloads and installs them. After a successful download, Clozure CL rebuilds itself, and then rebuilds the IDE on the newly-rebuilt Lisp. Once this process is finished, you should quit the running IDE and start the newly built one (which will be in the same place that the old one was).

Normally, Clozure CL can install updates and rebuild itself without any problems. Occasionally, an unforeseen problem (such as a network outage, or a hardware failure) might interrupt the self-rebuilding process, and leave your copy of Clozure CL unusable. If you are expecting to update your copy of Clozure CL frequently, it might be prudent to keep a backup copy of your working environment ready in case of such situtations. You can also always obtain a full, fresh copy of Clozure CL from Clozure's repository..

5.4.3. The Tools Menu

The tools menu provides access to the Apropos and Processes windows. The Apropos window searches the running Lisp image for symbols that match any text you enter. You can use the Apropos window to quickly find function names and other useful symbols. The Processes window lists all threads running in the current Lisp session. If you double-click a process entry, Clozure CL opens an Inspector window on that process.

5.4.4. The Inspector Window

The Inspector window displays information about a Lisp value. The information displayed varies from the very simple, in the case of a simple data value such as a character, to the complex, in the case of structured data such as lists or CLOS objects. The left-hand column of the window's display shows the names of the object's attributes; the righthand column shows the values associated with those attributes. You can inspect the values in the righthand column by double-clicking them.

Inspecting a value in the righthand column changes the Inspector window to display the double-clicked object. You can quickly navigate the fields of structured data this way, inspecting objects and the objects that they refer to. Navigation buttons at the top left of the window enable you to retrace your steps, backing up to return to previously-viewed objects, and going forward again to objects you navigated into previously.

You can change the contents of a structured object by evaluating expressions in a listener window. The refresh button (marked with a curved arrow) updates the display of the Inspector window, enabling you to quickly see the results of changing a data structure.

Previous Section Next Section Table of Contents Glossary Index